Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble

[Catalina] Cannot connect to ethernet with Realtek adapter

Recommended Posts


I know this is a common problem, but none of the solutions I found fixed it.
I can't get my ethernet adapter to work on Mac Os Catalina. It is working fine with Windows (installed on a separate partition and on other computers)

Adapter model: Realtek PCIe FE Family Controller VEN_10EC&DEV_8136&SUBSYS_1844103C

After install, the adapter was simply not detected at all. The ethernet interface was not available in network settings and the adapter did not appear in "system information".

LucyRTL8125Ethernet and Mieze's RealtekRTL8100 kext drivers had no effect.
I finally managed to get the adapter detected thanks to AppleRTL8169Ethernet.kext. An automatic Ethernet configuration was created in network settings.

BUT: I can't access to the internet. The cable is said to be unplugged. If I change the ethernet configuration, the message randomly changes to "Auto-assigned IP address", no matter whether the cable is plugged in or not.
I tried with several cables (all working on Windows).

During boot, white LEDs are on around the ethernet port (this is a normal behaviour) but they shut down at the end of the boot process (they should remain on).

I tried to enable or disable network boot in BIOS, to check/uncheck "allow the computer to turn down the device to save power" in Windows's device manager, but nothing works...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...