Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
  • Donation Goals

    Monthly Donation - May

    Hackintosh Shop was made possible by using your donations & displaying ads which covers the running cost.

    Donate with BitCoins

    Thanks


    20%
    $20.00 of $100.00 Donate Now
stom

BIG SUR ON LENOVO THINKPAD L590

Recommended Posts

Posted (edited)

I have a Lenovo ThinkPad L590 (R0ZET35W).
https://psref.lenovo.com/syspool/Sys/PDF/ThinkPad/ThinkPad_L590/ThinkPad_L590_Spec.pdf

I am trying to install Big Sur but no luck.
I used this distro : https://www.hackintoshshop.com/2810/hackintosh-big-sur-guide/
and EFI COFFEELAKE WHISKEYLAKE bootlader (EFI Folder)

The laptop boots from USB shows me 10-20 lines bootstrap code and then shutdown.
I tried also various EFI (config.plist) with clover or opencore, all failed and some shows error LOG:EXITBS:START.
I think the problem is the recognize of M2 NVME or i need a special DSDT patch.
Please help.

Edited by stom

Share this post


Link to post
Share on other sites

Post your laptop Specs here.

Share this post


Link to post
Share on other sites
On 4/30/2021 at 5:31 AM, stom said:

Laptop Lenovo Thinpad Business L590
-----------------------------------
CPU        : i7 8565U 8th Gen, 8 Logical cores
Audio      : Realtek
LAN        : Intel I219-V
WLAN       : Intel AC-9260
RAM        : 16 GB DDR4
Hard Disk  : TOSHIBA 512 GB NVMe
Graphics   : Intel UHD Graphics 620
Peripherals: USB3.1 Type C, HDMI, MicroSD, Camera, WWAN SIM, TPM, Goodix Fingerpint


 

 

Share this post


Link to post
Share on other sites

Does your mouse moves on  Second Image?

Share this post


Link to post
Share on other sites
22 hours ago, MacintoshOS said:

Does your mouse moves on  Second Image?

Yes mouse , caps lock key etc all working for about 1 hour. Percentage bar all the time was at this position.

After an hour all frozen and need to hard restart the system.

As you can see at the top right corner Big Sur setup recognize my laptop wifi and i connected to internet!

 

Share this post


Link to post
Share on other sites

Disconnect Wifi, It could be slowing down by downloading updates.

 

Share this post


Link to post
Share on other sites

yes i know i tried without wifi, same thing, hungs!

but the funny thing is that connected to internet!!

Share this post


Link to post
Share on other sites

Could you save and attach the Installer log here?

Share this post


Link to post
Share on other sites

Here is the link for main log installer :

MAIN LOG

Here is the link for pre-installer (before disk utility) :

PRE LOG

 

 

 

Share this post


Link to post
Share on other sites

There is nothing wrong with the Installer, but i could not detect why the Installer gets stuck.

Instead of trying this 

Download macOS Big Sur and Restore this image to another Pen drive.

Use the current Pen drive to load Clover bootloader, the Select the Other Pen drive volume to Boot from.

This is still vanilla and native way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...
close