Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
  • Donation Goals

    Hackintosh Monthly Donation - October

    Hackintosh Shop was made possible by using your donations & displaying ads. Thanks.


    10%
    $20.00 of $200.00 Donate Now
duo

[Solved] OSinstall.prescript.pkg problem

Recommended Posts

Straight and forward. MacOS could not be installed on your computer: an error occurred while running scripts from the package "OSinstall.prescript.pkg". I followed the High Sierra Hackintosh guide.

Share this post


Link to post
Share on other sites

Just to be clear: I’m running an AMD Ryzen 2600 and a nvidia 1070...

I applied the boot flag: “ncpi=0x2000 -v” in order to get past the PCI configuration stuck 

It then took me to the installation area and I applied the date command 

I tried installing multiple times but around the 1 minute left area it will give the MacOS cannot be installed error

Share this post


Link to post
Share on other sites

Can you attach the Installer log?

Sometimes even if the Installation was successful, The Installer could throw a false positive error.

Did the Installation Continue after the reboot, you must add npci=0x2000 again. Remove the USB to check if the boot-loader works.

Share this post


Link to post
Share on other sites

I need to restart the installation after reboot and add the npci=0x2000 again 
spacer.png

Share this post


Link to post
Share on other sites

You have named your Volume as Sam's Mac

As the single quote could mess with Scripts it might cause the issue, Just rename Volume as Sam and your Installation Could work.

Note: The date command is mandatory.

Share this post


Link to post
Share on other sites

Yes, the quotation mark is the culprit, I just tried it yesterday night.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...