Jump to content
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
  • Donation Goals

    Hackintosh Monthly Donation - September

    Hackintosh Shop was made possible by using your donations & displaying ads. Thanks.


    22%
    $45.00 of $200.00 Donate Now
  • 2
subotica77

Upgrade to Catalina 10.15.6 from Niresh 10.15

Question

I used your guide to install Niresh Catalina 10.15. How can I upgrade to the newest Mac OS version 10.15.6? I saw some tutorials online, but I'm just curious if they work with this installation.

 

I'm sorry for all these questions. I'm new to the Hackintosh community. Love it so far. :-)

Share this post


Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0

Its simple you can upgrade using the System Preferences. or Download Catalina Combo Updater.

Share this post


Link to post
Share on other sites
  • 0

No, it didn't work, it went through the update using System Preferences, but now it just shows black screen after Clover finishes loading. There has to be something else I need to change for it to work.

Share this post


Link to post
Share on other sites
  • 0

My setup (Niresh Catalina):
Motherboard: Gigabyte GA-X99-Ultra Gaming (rev. 1.0)
CPU: Intel Core i7 6950X Processor Extreme Edition
Ram: Corsair DOminator Platinum 3200MHz, 64GB
GPU: XFX Radeon RX 580 GTS XXX Edition

 

I event tried to replace the MacOS installer in the Niresh Catalina installer with the newest installer (10.25.6). It worked until I had to restart it the first time and change the boot disk to the built in disk. It went through the Clover loading, but when it got to the part when the install status bar was suppose to show up, it went to a black screen and stayed black.

Share this post


Link to post
Share on other sites
  • 0

@DarkZer0 - Köszönöm 😀, but I have an x99 motherboard,which is a little harder to emulate.

@Hackintosher - Thank you for that. Replacing Lilu & Whatevergreen worked to a certain extent. I was able to get further with the update process. This time when the updater restarted it actually started up from the installer partition, and I was able to see the the install progress. Unfortunately when the installer finished it restarted to a black screen. Clover is able to load, but when it gets to the part when the Apple logo usually shows up, it's just black.

So, I tried to make another USB using Restore Niresh Catalina.pkg. This time I replaced Lilu & Whatevergreen on the USB thumb drive, and I replaced the Install macOS Catalina.app with the newest version 15.6.00. I'm able to get to the installer part, then it starts installing, but it always stops with this error:

spacer.png

Maybe I'm missing some things in the confg file since I'm on x99 motherboard. I've been trying to get this working for many days now with no success. I also tried vanilla and unibeast, but so far I can only get it to with with niresh. But I can't upgrade to the latest Catalina. 😐

 

Share this post


Link to post
Share on other sites
  • 0
On 8/1/2020 at 2:57 AM, subotica77 said:

@DarkZer0 - Köszönöm 😀, but I have an x99 motherboard,which is a little harder to emulate.

@Hackintosher - Thank you for that. Replacing Lilu & Whatevergreen worked to a certain extent. I was able to get further with the update process. This time when the updater restarted it actually started up from the installer partition, and I was able to see the the install progress. Unfortunately when the installer finished it restarted to a black screen. Clover is able to load, but when it gets to the part when the Apple logo usually shows up, it's just black.

So, I tried to make another USB using Restore Niresh Catalina.pkg. This time I replaced Lilu & Whatevergreen on the USB thumb drive, and I replaced the Install macOS Catalina.app with the newest version 15.6.00. I'm able to get to the installer part, then it starts installing, but it always stops with this error:

spacer.png

Maybe I'm missing some things in the confg file since I'm on x99 motherboard. I've been trying to get this working for many days now with no success. I also tried vanilla and unibeast, but so far I can only get it to with with niresh. But I can't upgrade to the latest Catalina. 😐

 

I am also getting this error even from a fresh installation

Share this post


Link to post
Share on other sites
  • 0

@Hackintosher - I figured out how to save the installation log. Here is a link to my installer log: https://we.tl/t-PkpUbFGlCk

 

I'm hoping you can figure out why I'm not able to install the latest version of Catalina on my Hackintosh.

Share this post


Link to post
Share on other sites
  • 0
On 8/2/2020 at 9:06 AM, Hackintosher said:

Can you attach the Installer log please?

@Hackintosher - Here is a new download link for the log since the other one will expire in couple of days: https://we.tl/t-AwVAIp9OF0

 

Hopefully you have an idea how to get this working.

Share this post


Link to post
Share on other sites
  • 0

I finally figured out my problem. The problem is my video card (XFX Radeon RX 580 GTS XXX Edition). It works flawlessly in Catalina 10.15.0 but when I upgrade to 10.15.6, it goes to black after clover loads. The update from 15.0-15.6 was successful each time, but I couldn't see it. I swapped the video card for an EVGA GT 1030, and everything worked great (no Metal support though).

So, @Hackintosher , do you have any suggestions to get my XFX RX 580 working in the latest installation of Catalina? I saw on some forums they were saying to flash it with an older bios. I did, and it bricked the card. Luckily it has dual bios so I was able to restore it. Someone suggested to flash it with the Saphire bios of the same type of a card. I tried, but it wouldn't let me. Someone suggested to try the DP instead of HDMI... no difference.

I really don't want to have to buy a new card. There's got to be a way to get this working.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I ended up purchasing a Sapphire Radeon 580 Nitro, which is suppose to work with all hackintoshes, but it goes black after the Clover boot. I know the MacOS loads, but I can't see it. Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites
  • 0

Yes, I updated Whatevergreen to version 1.4.2. I also updated Lilu to 1.4.7

To sum it up:

The Hackintosh works flawlessly with both Radeon 580 and Nvidia GT 1030 on Catalina 10.15.0

Once updated to 10.15.6 it works with Nvidia (without hardware acceleration), but not with Radeon 580 (XFX or Sapphire). It's running because I can see it on the network, but it's producing no picture. I tried with all ports on the card, none of them work.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
On 7/31/2020 at 7:57 PM, subotica77 said:

@DarkZer0 - Köszönöm 😀, but I have an x99 motherboard,which is a little harder to emulate.

@Hackintosher - Thank you for that. Replacing Lilu & Whatevergreen worked to a certain extent. I was able to get further with the update process. This time when the updater restarted it actually started up from the installer partition, and I was able to see the the install progress. Unfortunately when the installer finished it restarted to a black screen. Clover is able to load, but when it gets to the part when the Apple logo usually shows up, it's just black.

So, I tried to make another USB using Restore Niresh Catalina.pkg. This time I replaced Lilu & Whatevergreen on the USB thumb drive, and I replaced the Install macOS Catalina.app with the newest version 15.6.00. I'm able to get to the installer part, then it starts installing, but it always stops with this error:

spacer.png

Maybe I'm missing some things in the confg file since I'm on x99 motherboard. I've been trying to get this working for many days now with no success. I also tried vanilla and unibeast, but so far I can only get it to with with niresh. But I can't upgrade to the latest Catalina. 😐

 

ok i had the same issue heres whatworked. go back to the beginning of the insatllation process. Reboot into the insatller and once there go to utilities and terminal and when terminal opens up type this without quotes "date 0824000019" then hit enter and it will change the date to the above. Then continue with your installprocess as usual and that should correct the error.

Share this post


Link to post
Share on other sites
  • 0

ok i had the same issue heres whatworked. go back to the beginning of the insatllation process. Reboot into the insatller and once there go to utilities and terminal and when terminal opens up type this without quotes "date 0824000019" then hit enter and it will change the date to the above. Then continue with your installprocess as usual and that should correct the error.  You have to change the date apparently to the year that catalina came out so if that dont work then modify the date i gave you to the date that the catalina 10.15.6 update officially came out. it should work

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...